Problem when using the .html suffix to reference a template location.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem when using the .html suffix to reference a template location.

LucDePauw
Hello,

In thymeleaf it's possible to have the resolver add a suffix ex. '.html' to the template name.
Since I don't want to do this, my template/fragment is referenced in thymeleaf like this 'fragment/common.html'
Thymol doesn't find the template if referenced like this th:include='fragment/common.html::headerFragment'  only this works
th:include='fragment/common::headerFragment'
But then my thymeleaf resolver failes...
Is there a way to define a prefix for the template in the thymol configuration ?

Thx

Luc
Reply | Threaded
Open this post in threaded view
|

Re: Problem when using the .html suffix to reference a template location.

jjbenson
Administrator
Hi Luc,

  I'm sorry to say that there is no such facility in Thymol - yet. If you would like to add an enhancement request via https://github.com/thymol/thymol.js/issues/new I will give it my attention.

  Kind Regards,

    Jim
Reply | Threaded
Open this post in threaded view
|

Re: Problem when using the .html suffix to reference a template location.

jjbenson
Administrator
In reply to this post by LucDePauw
Hi Luc,

  Thanks for raising the issue (#13). I've now delivered the enhancement you requested.

  Download the latest build from:

   https://github.com/thymol/thymol.js/tree/2.x-master

  (the sourceforge build is probably the easiest to use).

  Add the following to your config script:

    thTemplateSuffix = "";

  I hope this works for you!

  Kind Regards,

    Jim